pwgen/PKGBUILD

40 lines
900 B
Bash

# Maintainer: Maximilian Käfer <maxi@kske.dev>
pkgname='pwgen'
pkgver=1.0.r3.90939a6
pkgrel=1
pkgdesc="Random Password Generator CLI"
arch=('any')
url="https://git.kske.dev/DieGurke/pwgen"
license=('GPL')
groups=()
depends=('binutils' 'python')
makedepends=('git' 'python-setuptools')
checkupdates=()
optdepends=('bash')
provides=(pwgen)
conflicts=()
replaces=()
backup=()
options=()
source=("git+$url")
noextract=()
md5sums=('SKIP')
validpgpkeys=()
pkgver() {
cd ${pkgname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
python -m setuptools.launch setup.py build
}
package() {
cd ${pkgname}
install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm755 pwgen.sh "${pkgdir}/usr/bin/pwgen"
python setup.py install --root="$pkgdir" --optimize=1
}